•  

    Click HERE to join our forum and participate in the discussions.

     

Hard starting 1989 B2.......


duffy

Member
Joined
Jan 12, 2020
Messages
33
Reaction score
11
Points
8
Vehicle Year
1989
Vehicle
Ford Bronco II
I just got this B2 last weekend......when it has sat overnight it takes a lot of cranking to get it started. Once started and ran for a few minutes it will re-start just fine. I am thinking that something (the fuel pump possibly) isn't holding pressure. I was told by PO that it also has an in-operative fuel gauge (reads empty with the key ON and about 1/8 tank with the key OFF). I don't like to just throw parts at a vehicle but I am unable to read/check fuel pressure. Am I on the right track with changing the fuel pump/sending unit assembly?
 


JerryC

Member
Joined
Apr 10, 2014
Messages
502
Reaction score
18
Points
18
Vehicle Year
1988
Vehicle
Ford
Get FP tester at Harbor Freight or see if you can get a loaner at the local parts store.
You may just need a regulator or a new filter. If you are going to throw parts at it, filter would be the one I try first, then regulator and last the pump.
However if you are going to replace the fuel gauge sending unit, you may as well do the pump.
 

duffy

Member
Joined
Jan 12, 2020
Messages
33
Reaction score
11
Points
8
Vehicle Year
1989
Vehicle
Ford Bronco II
I've done a bit more thinking and research (it just runs too good after starting to indicate a fuel pump). I tested a theory. I installed a recirculating heater in the heater hose and plugged it in for about 4 hours. Vehicle fired right up, which tells me the fuel pump is probably good. I'm thinking that the temp sensor for the ECM may just be bad (not indicating cold temp to the ECM for enrichment). The sensor for the water temp gauge works when the vehicle is warmed up at idle. Goes to about 1/4 reading. I have a new thermostat so I do believe I'll change it and the ECM temp sensor and see what shakes out.

I'm way out in the boonies so borrowing a FP gauge isn't to practical. I do have an external oil pressure gauge (a real good one) and lots of different fitting though, might that work? Is the FP read at the fuel rail shrader valve? Yeah, no books yet. I do have internet though, that's how I get most of my parts and information. Thanks
 

JerryC

Member
Joined
Apr 10, 2014
Messages
502
Reaction score
18
Points
18
Vehicle Year
1988
Vehicle
Ford
I think you're probably on the right track. There is to test the coolant temp sensor, I did it a long time ago. The procedure is probably on this site or the TheRangerStaion tech pages.
Don't forget to check the harness and connector.
 

duffy

Member
Joined
Jan 12, 2020
Messages
33
Reaction score
11
Points
8
Vehicle Year
1989
Vehicle
Ford Bronco II
I found the test procedure....thanks.
 

alwaysFlOoReD

Blang - not bling
Forum Moderator
Joined
Apr 13, 2009
Messages
188
Reaction score
35
Points
28
Location
Red Deer, Canada
Vehicle Year
'91, '93, '98
Vehicle
Various
Engine Size
4.0, 4.0, 4.6
Suspension Style
4wd
So each time the key is turned on (engine not started) the fuel pump runs for about 2 seconds. Each time the fuel pump runs the fuel pressure goes up 10psi. Assuming there is an internal leak in the fuel system.... If the pressure is at 0 then turning the key on 4 times will build pressure to the 40psi that the system needs.
Try turning the key on 4 times before starting and see if there is a difference.
 

duffy

Member
Joined
Jan 12, 2020
Messages
33
Reaction score
11
Points
8
Vehicle Year
1989
Vehicle
Ford Bronco II
Okay, a bit more info........I tried the multiple key turns (the pump runs for a couple of seconds) tried 4 times and engine fired but didn't run. Gave it another 6 turns and the engine fired right up and idled at about 1350-1400 (the temp here was in the upper 40's), after a minute or two of idling the rpm's dropped to 1000. After running for about 10 minutes ( I was doing other things) I checked the idle and it was at 750-800 and the temp was in the normal range. Now that tells me that the ETC is good and the fuel pressure is bleeding off somewhere. From my research it looks like one of two things, the fuel pressure regulator on the rail (should there still be 40 psi at the rail after sitting overnight?) or the fuel pump in the tank (1989). I have to change out the fuel gauge sender so I guess the pump gets changed at the same time.
 

alwaysFlOoReD

Blang - not bling
Forum Moderator
Joined
Apr 13, 2009
Messages
188
Reaction score
35
Points
28
Location
Red Deer, Canada
Vehicle Year
'91, '93, '98
Vehicle
Various
Engine Size
4.0, 4.0, 4.6
Suspension Style
4wd
Fuel pressure should stay at/near 40psi for months.
FPR - pull the vacuum line and look and small for gas. If signs of gas found the diaphragm has ruptured. Pinch the vacuum line and fuel pressure should go up.
 

JerryC

Member
Joined
Apr 10, 2014
Messages
502
Reaction score
18
Points
18
Vehicle Year
1988
Vehicle
Ford
Don't forget that fuel can leak through an injector.
 

duffy

Member
Joined
Jan 12, 2020
Messages
33
Reaction score
11
Points
8
Vehicle Year
1989
Vehicle
Ford Bronco II
Checked the regulator vacuum this morning.....no fuel smell. The vehicle did start right up after 4 ignition switch cycles though. I'm going to see if my oil gauge can read the fuel pressure then I think I'll just change out the fuel sender/pump and see what happens. Would be nice if the gauge and the fuel pressure gets "fixed" at the same time. Thanks for the help.
 

duffy

Member
Joined
Jan 12, 2020
Messages
33
Reaction score
11
Points
8
Vehicle Year
1989
Vehicle
Ford Bronco II
Well finally got the fuel pump/sending unit changed today. The vehicle started after cranking for less than 10 seconds. I'll check it again tomorrow after it sits for a day. Hopefully it will fire right up. If not then it's fuel pressure regulator time. The fuel gauge works good now........I found the brass float laying on the bottom of the tank (I may have knocked it loose getting the unit out of the tank). It was not floating however. I'm glad I made an access door to the pump, cause the tank was over half full. That would not have been fun dropping that.
 

duffy

Member
Joined
Jan 12, 2020
Messages
33
Reaction score
11
Points
8
Vehicle Year
1989
Vehicle
Ford Bronco II
Still cranks 6-8 seconds before it sputters to life and then smooths out. I did notice another thing however, I can't put it in gear right away or it will die, it does run at about 1350 rpm give or take a bit. I think I'll investigate the enrichment circuit before I change the pressure regulator. It's streetable now however.
 

duffy

Member
Joined
Jan 12, 2020
Messages
33
Reaction score
11
Points
8
Vehicle Year
1989
Vehicle
Ford Bronco II
Left the B2 set for two days and did some tinkering on minor things. Hopped in it this morning and it fired up in about 3-4 seconds. I do believe I'll call that "fixed".
 

JerryC

Member
Joined
Apr 10, 2014
Messages
502
Reaction score
18
Points
18
Vehicle Year
1988
Vehicle
Ford
When I replaced my FP/sender combination (actually a shop did it) the fuel gauge started to mess up after a a couple of tankfuls. Since the shop screwed up a couple of other minor things like not tightening the clamps on the filler hose and other general half ass-ery I went to work on the issue. I used an inspection camera to verify the float was sunk and ordered a plastic float, it also fits a jeep of some sort. That has worked since.
FWIW, the FP/Sender unit was a NOS Motorcraft.

The access panel for the the fp/sender has saved me a lot of time, I went back several times before I fixed all the things that they didn't do correctly.
 

duffy

Member
Joined
Jan 12, 2020
Messages
33
Reaction score
11
Points
8
Vehicle Year
1989
Vehicle
Ford Bronco II
I thought about just changing just the float but I had fuel pressure problems also. Changing the whole assembly fixed both my problems. Starts good now and the fuel gauge works and even seems to be accurate.

I miss positioned my access panel a bit (still works) but should have been a bit farther back.
 

Top